R

Sat, Jan 16, 2021 12:43 AM

Anyone else have to wait over five minutes for an alarm to be reported

My alarm was just tripped by a family member who was meant to be there mind you but.  I was unable to deactivate the alarm because on all my devices and the web it appears I never had an alarm by SimpliSafe. The real issue I have is that it took the alarm monitoring company over five minutes to call me and inform me of a 'break in'  If this was a home invasion or even a fire this is far too long to wait for a service we all pay 25 dollars a month more.  If this was Wyze I could sort of understand. I was told they were busy which is why it took longer. So had it been a fire or home invasion they were busy.Don't worry.

23 Messages

Il y a 1 a

Your base's cell connection might not be stable. Make sure to put it next to a window that has good cell connection, and place it on a wooden surface. Put your system into test mode (https://support.simplisafe.com/hc/en-us/articles/360029485592-How-do-I-test-my-SimpliSafe-system-and-devices-How-do-I-know-my-system-and-devices-are-working-)

and see if you get a call.

If the wait time is still five mins. or longer, call Simplisafe customer support and demand for answers, or ask them if you could upgrade to a new cell module with a different provider or a different base station altogether. Usually, they would provide it for free, assuming that you would need to send back your old equipment.

If you can, please post your outcomes here.


Best of luck!

Community Admin

 • 

2.9K Messages

Il y a 1 a

robtrench's question was from way back in January - so they might have already gotten their issue resolved. But yep, I would definitely recommend giving our Support team a call at 800-548-9508 so hey can help triple-check that the Base Station is properly connected.

- Johnny M.
SimpliSafe Home Security