J

Fri, Jul 30, 2021 11:12 PM

Base station WiFi does not automatically connect after v2.1.18 firmware update.

To reproduce the problem:

1.  Manually configure the WiFi settings on the base station.
2.  Confirm that the base station is connected to the wireless network.
3.  Power off the WiFi router/AP or disable the WiFi network.
4.  Confirm that the base station has lost its wireless network connection
5.  Power on the WiFi router/AP or enable the WiFi network.
6.  Wait the wireless network to become available.
7.  The base station should automatically connect to the WiFi network but it does not.

After the SimpliSafe Gen 3 base station firmware upgrade to v2.1.18, the base station will no longer automatically reconnect to the wireless network.  In order to reconnect, one must manually configure the WiFi setting each time the wireless network connection is lost,  Prior to this firmware update, the base station always re-connected by itself shortly after the wireless network becomes available.

On the router, there is no indication that the base station is even trying to re-connect.  The log does not show any association attempts.  All of the other wireless devices reconnect just fine, including the SimpliCam.  However, the base station just remains silent.

Please investigate and fix.

In the meantime is there a method to downgrade the base station firmware?

-John

Advocate

 • 

636 Messages

1年前

I have not had this problem. My SimpliSafe system reconnects without issue. However, I have not only reproduced the case as described above, but my power has gone out 3-4 times (for hours) since applying the most recent update (Northern California problems). Each time I check to see if cellular is the primary throughout - it is. As soon as my router and modem are back online, Wi-Fi restoration to my system takes place/takes over as the primary connection.

Advocate

 • 

636 Messages

1年前

I was wrong; you were correct, JohnC60.

I decided to test it again less than an hour ago. I received the push alert informing me of the Wi-Fi disconnection to the Base Station. As with previous times, I waited to receive the restoration alert, and 30 minutes later, it still was on cellular. The only way to get it to reconnect was to, as you said, re-enter my Wi-Fi network's password. The Base immediately reconnected, and I received the push alert. Nothing else (refreshing the system via app and website, rebooting the Base Station, etc.) worked.

SimpliSafe, please fix.

Community Admin

 • 

2.9K Messages

1年前

Thanks for reporting, JohnC60 and Shiherlis!

I'm checking with our engineers to get more info about this.

- Johnny M.
SimpliSafe Home Security

3 Messages

3分前

This is still happening after the April 2022 update

Community Admin

 • 

2.9K Messages

@jasonmckay117​ thanks for reporting. One question for you: Is it that your router just isn't accepting the connection, or is the WiFi info completely disappearing from your Base Station's memory? You can check by navigating on the Keypad to Menu > System Settings > WiFi.

And does the Base Station reconnect by itself if you do a power cycle instead? That is, unplug the unit, and take out one battery, then putting it back together.

(edited)

3 Messages

Wifi Setting drop from the Base Station.  I have to reconnect to the WiFI connection and re-enter credentials.  Nothing else on my network drops the WiFi connection like this.  I also unplugged the base station and removed the batteries for 10 minutes.  It still drops the WiFi settings after 24-48 hours.

Community Admin

 • 

2.9K Messages

Hi @jasonmckay117,

It's still not clear to me. When you go to the WiFi section in your Keypad's Menu, the settings there are completely gone? Normally, you'd be shown what WiFi the Base Station is currently connected to.

2 Messages

2分前

Same issue here after latest firmware update... it seems to remember the network but won't connect.  I have to use the keypad to tell it to forget the network, then reconnect and re-enter Wifi password, then it's fine if/until the Wifi reboots again (e.g. power outage or other reboot)

2 Messages

I should add - since this started happening, I have upgraded my WiFi base station to a new unit, different brand; same issue.  So I am pretty sure it's a SimpliSafe Base Station issue, not a WiFi router issue.

Community Admin

 • 

2.9K Messages

@bwallis99​ I suspect that it might be an issue with how your router handles traffic, or perhaps something in your router's security settings. You might want to try setting up a Guest WiFi network, which only your SimpliSafe components connect to.

1 Message

I have the exact same issue. Base Station does not reconnect to network automatically. Talked to a tech at Simplisafe and was told this is a known problem and has been escalated. There is a bug in the Base Station Firmware and the tech pretty much agreed... It's a pain, if I'm aware for an extended period and the network drops for whatever reason, the system is disconnected from the network and it has to rely on Cell until i am able to get back to the house and log into the Simplisafe via the keypad.  Hopefully this gets fixed soon.

Community Admin

 • 

2.9K Messages

Hi @jlee2070 ,

I would disagree with that assessment. I'm a little closer to the devs, and I haven't heard of that being a known issue. But I'll definitely look into it, now that you bring it up.

1 Message

1分前

I have the same issue. Just got the system a couple days ago. I don’t have dedicated home Wi-Fi system yet so I use my phone as hotspot while I’m figuring things out. I leave my hotspot on continually (iphone13). Each time I leave the house and come back, I have to manually enter the password through app to reconnect to my hotspot.

Community Admin

 • 

2.9K Messages

@joshbpic​ ah, unfortunately your particular scenario isn't supported at all. Hotspots via mobile device work very differently from connecting to a standard access point (router, node, etc.).

But do you also have active Monitoring Service? If so, your Base Station does have its own built-in cellular connection. So it can go without WiFi entirely, in the meantime.