E

Sat, Dec 29, 2018 12:54 AM

Doorbell camera will not ring doorbell

I installed our doorbell camera and when I push the button it does not ring and the led light does not blink. It will ring one time when I slide the camera on the base but not when I push the button

Accepted Solution

5 Messages

Il y a 4 y

This sounds like a simple problem with the wiring. Try disconnecting and reconnecting the wires to the base. It's important that you follow the directions and guide the existing wires behind the screw plates and bending the wires to "fit" tightly to the posts before tightening. If this doesn't work, then it sounds like something is interfering with the contacts and may need to be replaced. The installation is simple and doorbell wiring is as well. Good luck!

Community Admin

 • 

2.9K Messages

This is the correct advice. It sounds like the issue is with the wiring, and the above lays some good troubleshooting steps.

If OP had been seeing that the Video Doorbell Pro is in fact properly powered, but just isn't producing sound, or conversely is producing a constant buzzing from the doorbell speaker, then they might need a Chime Connector. You can learn more here.

3 Messages

Il y a 4 y

I connected the chime connector to the doorbell in the house. The camera works fine but the only way the doorbell in the house will chime is if you hold down on the button continuously
Note: This comment was created from a merged conversation originally titled Doorbell camera will ring doorbell if finger is held on outside button continually

7 Messages

Mine did the same thing. At first they sent me a chime connector which did not work. After that it was determined that my chime was not compatible with the doorbell. When I asked what kind IS compatible so I could replace it, they didn't know. Back it went.

96 Messages

Perhaps you require a higher voltage doorbell transformer?

Community Admin

 • 

2.9K Messages

From this update, it sounds like the doorbell is still not getting the correct voltage. Our Support team at 800-548-9508 may still be able to help with further solutions - which might include a replacement unit.

1 Message

Il y a 3 y

Also having this issue. Curious if there was a resolution?

My wiring is tight and clean, via the screwplate. Same issue of it ringing once when putting faceplate on, but then...nothing. No power, no ability to ring, no lights.

1 Message

Il y a 3 y

Any update to this problem? I have installed the doorbell. Checked wiring. Did it again. Made sure wiring looked good. Old doorbell works fine, but new SS doorbell won't even ring.

1 Message

Il y a 3 y

Same issue here. Exact same issue.  And found out only network it will connect to is 2.4.  About to take to Twitter to let world know that this is one very poor device.  What a pity.

171 Messages

Il y a 3 y

It actually is a good doorbell.  Mine is working just like Ring Pro, perhaps in some ways better.

Do any of you with problems have a digital doorbell?  I don't think the Simplisafe doorbell works with digital doorbells.

Advocate

 • 

541 Messages

Il y a 3 y

If its a digital doorbell then you have to get the chime connector which is easy to install. Mine did nothing but hum when i installed it and soon as i hooked up chime connector it works perfectly.
So would a chime connector also fix my issue which is constant ringing when connected?

1 Message

Il y a 3 y

Just installed my second unit, installed doorbell camera and when I push the button it does not ring the inside bell, but  the led light does blink and the camera unit itself sounds, but inside bell doesn't ring. The inside bell will ring, one time when I slide the camera unit on the base but not when I push button.  Checked voltage and it is 20v and now the unit will not light up at all.

Captain

 • 

4.6K Messages

Il y a 3 y

@rob_24720200583924 I am not sure the chime connector will work on a digital. Analog only. Suggest you call SS to confirm.

2 Messages

Il y a 3 y

I am having the same issue.  I have had 2 different techs come out to try to get it working.

Slide it on, the bell rings. then nothing, no lights, nothing.

SS sent me a new doorbell but that one  doesn't work at all, not even initially.

I have the chime connector in place and voltage is correct.  any other thoughts?

1 Message

Il y a 4 m

Not happy at all.  Their door lock is inconsistent and I’m tired of replacement parts. I also didn’t realize that there needs to be internet to work at all.  If I’m gone for months I’m not paying them and internet. The door and windows alert sends error messages.  I shouldn’t have to go through the many steps to delete it and reset the entire system.  For a single older person with disabilities I don’t recommend it. 

 

This comment has been converted into a post

2 Messages

Il y a 3 m

I'm having the same issue: The video on my SS doorbell camera works and the bell will ring at the unit, but nothing inside.  I've tried deleting the camera and reinstalling it.  It will ring once inside and then go back to not ringing inside at all.  I've had this problem for the last four months.  Any suggestions?

Community Admin

 • 

2.9K Messages

@reed_hines​ do you mean that there's no ringing from the actual doorbell box? If so, that might be a circuit issue, and you may need a Chime Connector. Learn more here.

(edited)