J

Tue, Mar 3, 2020 10:03 PM

How to work around WrongBaseStationVersion response?

Sorry if this has been asked before. I am finally getting around to dealing with the retirement of the legacy APIs that was announced a few weeks back. I obviously have an older system and I'm trying to update my nightly "arm at midnight" script.

Futzing around with the new API endpoints in Postman, I eventually got this back when trying to set the system alarm state:

{
   "type": "WrongBaseStationVersion",
   "message": "Base station version was not 3!",
   "code": "077",
   "statusCode": 406,
   "props": {}
}

I did see some people's githubs using a URL like this, I but I got no response when I tried it:

https://api.simplisafe.com/v1/ss2/subscriptions/NNNNNN/state/home

Do I have to upgrade my system? Or is there any other endpoint I can try?

1 Message

Il y a 2 y

I have search for hours to try and figure out this WrongBaseStationVersion issue? Did you ever find a solution? I can't believe this is not happening to a lot of people out there?