V

Thu, Jan 2, 2020 8:51 PM

Keypad not connected

Hello all

Bought a new SS system and turned it on. The key pad keeps throwing error of "keypad not connected" when the base station is right next to it. I did try to remove the battery compartment in the base station and also tried to reset by pressing the white button in the base station. No luck. Simplisafe keeps powering up and i get the message of Welcome to simplisafe

This has been a frustrating experience. I tried reaching customer support and was on hold for an hour but still could not get anyone to speak with

This is a horrible product with a terrible customer support. The great reviews on public domain looks to me all fake or paid, given this is such a poor product and customer service. I am ready to ship this back but cannot do it until they print a label for which i need to get to talk to someone. Again a complex process

Any other suggestion from anyone who had luck to get out of this issue ?

1 Message

3 y ago

I'm having the same problem setting up a new system, the keypad is not connecting to the base station.

Advocate

 • 

2.8K Messages

3 y ago

^  If you've re-booted the base station and the keypad still won't connect, try rebooting it again.

You can also try taking out the batteries from the keypad, waiting a few moments, reinserting the batteries, then see if it will connect.

Make sure there isn't any wireless interference around the base or the keypad, nor anything blocking 'line of sight' between them, such as appliances, thick walls, or that the distance is too far apart.

Otherwise, call SS for troubleshooting.

1 Message

3 y ago

I have the exactly same issues. So frustrating!
Tried everything thats suggested in this forum. No Joy!!
Wish me luck if i can get someone to talk to get the refund.