A

Sun, May 2, 2021 5:25 PM

My Camera Install & Other Feedback

I'm not a computer expert anymore or an Internet expert ever. I am a retired techie and instruction manual writer who used to teach, install, repair and explain computer stuff. I follow instructions well.

WEBSITE FEEDBACK
The topics at the top of the homepage don't have "Support' or "Help' among them. These are only listed over scrolling past the several screen length sales pitches to the very bottom of the homepage. It's not good to make people having difficulties to dig to find help.

By the main topic "Contact' is the phone number, which is then immediately followed by an icon of a person's head in a circle, then a cart icon. From its placement the head icon could be taken by some people as "contact a real person' but it is really the login. It would help to have the words "Log In' beside that head icon instead of "Log In' only being revealed on the home page when mouse overing that head icon,  especially since other topics on the homepage (i.e., Features, Monitoring, Simplicam, etc.) don't use mouseover at all - so why would everyone have to guess mouseover would be the route to Log In? Yes, some would guess that ... and some wouldn't. Play it safe, please make it very obvious.

The topic "Monitoring' on the homepage is a sales pitch. The topic "Monitoring' available after logging in is for the user's contact info and monitoring settings. The topic name needs to be changed for one or the other so people don't think "Oh, I've already seen what Monitoring is' when they haven't seen both of these different results from a single named topic.

ACCOUNT SETUP
When setting up an account on the day of my purchase, SimpliSafe's setup automatically defaulted to a wrong county for my covered address. There was no way for me to change this wrong information. When I called customer support, the reply was to "don't worry about it, we can change it after your system is installed.'

CAMERA SETUP
The cameras wouldn't install. After showing them a QR code as part of their setup, the diagnostic cam lights would blink, "connecting to WiFi' would show, then the cameras would blink off and the app would reset to show the QR code again. Rinse and repeat ad infinitum. All of the listed setup requirements were met; it made no change. No install was possible.

A call to customer service resulted to new cameras being sent to replace the ones in my initial order. The day the replacement cameras were supposed to arrive, they didn't. The delivery service tracking said they were on the truck to be delivered, but instead returned to the sender because of an address problem. However, it was the same address my original order had been sent to with no delivery problem then. But this time it was a delivery service which didn't deliver to a post office box. I had no idea a different shipping service was used this time as SimpliSafe didn't mention it and I had no reason to suspect a different service would be used. This required yet another contact to customer service to get another set of replacement cams to be sent. When asked "What happens if the replacement cams have the same problems I have now?' customer service replied "Then we'll check your router' which had already been done earlier (2.4 GHz network, other devices accessing that network from the same spot as the cams, base station distance literally sitting on top of the router, accurate password, base station accessing fine). SimpliSafe seemed to still be unaware of the limits of this same delivery service, but this time I was contacted by the delivery service and gave them my street address for delivery.

This second set of replacement cams had the same problem as my original cams. Sigh. A week wasted since my original order arrived.

Remember the Account Setup problem with the wrong county appearing on the covered address preventing the Account Setup from being completed? The Account Setup which could be completed after install? Turns out the cams as part of their install process need an existing Account Setup to have been completed although it was never mentioned anywhere on any company info (webpage or printed setup material or customer service). Perhaps they needed the Account Setup already in place before the cams could send a test signal or something like that, that's just my uneducated eventual guess. The solution of getting the correct county to attach to my covered address (through live customer service) did finish the Account Setup in spite of the installation not being finished was the solution I came up with (customer service did not). After that, the camera install worked.

The minuses of SimpliSafe were the camera install difficulties, having to come up with my own solution to solve the problem with customer service being unaware of how to fix it, the shipping delivery for replacements not being able to deliver to an address the original order delivery shipped to without a problem, and the website being unclear and lengthening the time to find support info.
The plusses? The customer service staff was calm and polite. The setup for non-camera devices was quick and easy.

I can't give SimpliSafe better than a 3 out of 5 rating.
No Responses!