K

Tue, Jan 14, 2020 1:15 PM

New Entry Sensor does not light up

I recently upgraded from the SS2 to the SS3 system, and while installing the new system I noticed that 1 of the Entry Sensor's does not light up/flash blue as the magnet comes in and out of contact with it. I do hear the base station "chime" when the sensor and magnet are within proximity of each other, however the blue light does not blink on it. I have tried swapping out the battery with a known good battery and even removed the device from the keypad menu and re-added it again and it still does not light up. Is the sensor defective? The other 3 entry sensor's work just fine.

I called Customer Service last night but gave up after being on hold for a half hour. I also emailed them, but not sure whether I will get a response. Any feedback is appreciated! Thanks.

1 Message

3 y ago

I just installed my system today.  I have not been able to get a person at Customer Service but I have had very quick and good response from Technical Support at (855) 693-4911.  I called them through my phone app.

Captain

 • 

4.6K Messages

3 y ago

@kdrymer it sounds like a defective unit, so you will have to call to get it replaced.

Advocate

 • 

2.8K Messages

3 y ago

rnunnelley,  that number is for COPS Monitoring, please don't bother them with simplisafe problems, they are for MONITORING and Emergency purposes only and have nothing to do with simplisafe "technical support".

3 y ago

I have several new entry sensors that cannot be added as new devices.  I have followed the instructions, but continue to get a message that the device cannot be found.  This happened with 3 of the entry sensors.  There were no problems with the other entry sensor.  The system is new.

Advocate

 • 

2.8K Messages

3 y ago

If SS3, check your keypad (under Devices), or, if you have the interactive monitoring plan, from your online control panel (under Devices) - to see if they were already pre-entered by SS when shipped (you can also try installing them from the Devices page if they are not listed there).  If not, unfortunately, you'll have to call SS for assistance - try calling in the mornings when they first open (9 am, ET), and press #1 for sales.