R

Fri, Nov 20, 2020 2:10 AM

Old base station cell phone connection for 24x7 monitoring retired. New electronics did not work. Replacement not an option.

$700+ to upgrade to the next generation Simplisafe because I had the misfortune to be stupid enough to buy and expand a first-generation system?!

By the way, when we called tech support earlier this week (or late last week), shipping out a replacement old-style base station was not going to be a problem...

2 Messages

2 y ago

PS - so now the $25/month I pay is trash - my old-generation base station cannot communicate with the dispatchers. Something is wrong in customer service somewhere...

Advocate

 • 

2.8K Messages

2 y ago

Not sure I'm understanding your post - do you mean you bought SS3 system components to work with your SS2 system, or are you talking about something else? (SS3 components will not work with SS2, only the simplicams and video doorbell will work with both systems).

Otherwise, could you be a bit more clear what your complaint is?

1.3K Messages

2 y ago

Sounds to me like a rant about the 2G cellular modem in the Original SS system.

Should be easily resolved by installing the new LTE modem into the Original SS base. Perhaps the OP is unable to do the installation, or there has been a problem with the SIM not properly registered (as happened to me and a few others).

Captain

 • 

4.7K Messages

2 y ago

@ ragland when did you buy your system? When did you expand it?  Did SS offer to send you a replacement comm board for your system? I have placed many systems, both SS2 and 3, and ALL are working either with the original board or SS has sent them new boards to be replaced.  I can't believe SS is going to leave you hanging as you, as many, are the cash cows with monitoring. No useable base, no need for monitoring, no cash stream.  Please post back here.

In the interim, SS, can someone reach out to him or her?

Advocate

 • 

2.8K Messages

2 y ago

Well after several times reading OP's post, I finally got it, lol.  Yep, sounds like either needs a new 4G module/SIM for the base station, or if it already has it, needs to be activated by SS from their end.

@ragland, please call SS to discuss the issue, ask if the module is 4G compatible, and if it's activated.