R

Mon, Jan 13, 2020 12:54 AM

Phone app not working

My phone app is not functioning. When I try to use it the dashboard buttons are not highlighted. Tried dumping the app and reloading, still nothing. The alarm works if I set it manually or if I login into my account. In both instances I can set the alarm. Called Simplisafe and have been on hold for close to 45 minutes and counting. I called sales just to see if anybody was home and got through immediately. Of course the sales guy would not/could not help me. Very frustrated, anybody know what's going on?

12 Messages

Il y a 3 y

Seems like it's an update issue. Lots of people are having the same problem, including myself.

1 Message

It does seem to be an update problem.  On my apple phone  I ha security warning and went to settings, general, software update and ran the update and I was fixed.  Hope it works for you.

Captain

 • 

4.6K Messages

Il y a 3 y

@robinhirsch just want to confirm you have the 24.99 plan. You need it for the phone app to work. The $15 does not support it.

Advocate

 • 

541 Messages

Il y a 3 y

Yes a lot of people are having issues but i think its with the ios app and not affecting the android app as all of our apps are good even with updating but they always seem to have issues with the ios app which is another reason i will never have an apple phone lol

1 Message

Il y a 3 y

I'm having the same issue with the app on iOS for iPad and iphone.  Works through a web browser though...

292 Messages

Il y a 3 y

They pushed out an update yesterday with a fix.
those who are having issues, have you updated the app again?

4 Messages

Il y a 3 y

Same problem here. Updated app very unreliable on iOS. I did the second update and it solved the issue of the greyed out dash, but yesterday and today the phone app and the desktop access don't work. Getting connection errors. Functionality from keypad is fine.
Very frustrating as this obviously has not been fixed!

1 Message

Il y a 2 y

iPhone Mobile App still NOT able to login.  Worked for over an hour with SimpliSafe tech support and they can't figure it out either.  I can login via safari on my iPhone and via a web browser on my laptop.

Very frustrating as this obviously has not been fixed!

10 Messages

I am have the same issue on Android and my home PC's. You would be advised to start a new thread as this thread is old.

Il y a 2 y

I am on Android 8 OnePlus 3T and the app hasn't been working for over a week. Today 3/16/2020 I uninstalled, installed, rebooted phone, emptied cache and deleted app storage. Still not working. Additionally, base station is not connecting to the data center. I have the old alarm system and pay the $25/m service fee. I have reset the base station by unplugging and removing 1 battery for 15 seconds. I also replaced the batteries.

Advocate

 • 

2.8K Messages

Il y a 2 y

^  do you mean you replaced the base station batteries?  Hopefully you used suitable rechargeable batteries, because other (i.e., alkaline) batteries aren't going to work and could start a fire.

1 Message

Il y a 2 y

Here we are 25 April 2020 and the app still doesn't work. Mine stopped working 3 months ago, they sent me a new Verizon module and nothing changed. I've been installing the new app every time an update comes out with no luck. I'm done with this company! That haven't returned my emails and seems like they don't care about their customers. I'm buying a Ring system, their monthly fee is way less anyway. Thanks for nothing Simplisafe

9 Messages

There is a problem.  There are a couple other threads where one individual says Simplisafe has to "fully" activate the SIM card in the new module.  I had this problem for almost a month.  The rep says the card is activated but after getting the new 4g card, a new base station, a new, new 4g card, I still could not access the base station through my android, ipad, or the web on my laptop.  It is scary but Simplisafe is clueless and apparently lacks the structure to push this issue up the chain.  The situation is aggravated further by the fact that they're all working from home. They gave up on me and sent me a brand new updated SYSTEM for free.  I didn't even have to ask....nor was I belligerent on the phone.  It was a bit of a pain to replace my sensors, but I only had 10 of them.  Ask for a new system if they can't figure it out. For reference, I received my first 4g card the last week of March.

1.2K Messages

Il y a 2 y

3 Months?  That sucks.  Glad our 3 Androids and 1 iPhone are still working fine over here.

6 Messages

Il y a 2 y

I had an issue with my iphone app for months and called this morning based on some feedback on another thread.  

A WONDERFUL CUSTOMER SERVICE REP NAMED RHONDA (BOISE) AND TECH SUPPORT ASSOCIATE NAMED MARNAE (CENTRAL FL, EXT. 947) WERE ABLE TO HELP ME AND FIX THIS ISSUE.  

MARNAE HAS A LOT OF EXPERIENCE WITH APP ISSUES, SO I WOULD RECOMMEND CALLING HER AS NOT EVERYONE AT SIMPLISAFE SEEMS AS FAMILIAR.  

For me, the issue was related to the SIM card.