pxknw's profile

Mon, May 2, 2022 4:54 PM

Problems since Cell Module replacement

Ever since the 4G Cell Module install my system has been having weekly problems with the keypad unable to connect to base station.  Anyone else having problems since module replacement?

Official Solution

Community Admin

 • 

2.9K Messages

3 m ago

@lorized and @pxknw ,

This happens frequently for both of you? A Base Station replacement is definitely the way to go.

@pxknw, please call our Support team at 800-548-9508 and we'll get it sorted.

4 Messages

@davey_d​ 

Thank you, Davey. I called the Support Team and spoke with Ashanti.  She was awesome and after conducting a troubleshoot procedure, agreed that the Base Station needed to be replaced.  A new one is on the way and I look forward to my SimpliSafe system being back up and running properly reliable.

2 Messages

3 m ago

Me!  I just noticed that we are also having that problem.  How has this problem been resolved?

4 Messages

3 m ago

I don't think SimpliSafe has recognized this yet as a "Known Issue", and they have obviously not replied on this thread. I usually remove the batteries to the keypad for a few moments.  Once restarted, it's a roll of the dice.  Sometimes it simply wants a Master Pin selected. Other times I have to reconnect all the sensor devices. Sometimes I have to go the full route of rebooting the Base Station.  Prior to this cell module replacement, the system was very reliable.  I hope they do know and will address it soon.

2 Messages

@pxknw​  On our end, the base station was no longer responsive (no light, no notification of power outage if unplugged, no door chimes, etc). I called their 800 number last night and they confirmed that our base station stopped reporting a few days ago.  They are sending us a replacement.  

4 Messages

Great to hear, lorized