W

Thu, Apr 1, 2021 1:50 PM

SimpliSafe App Not Working (Android)

Is there something going on with the app? It used to work, but stopped a few weeks ago. I tried re-installing and it still does not function properly. Tested on a Samsung Note 10+, Samsung Note 8, and a Samsung S9. The cameras work sometimes, but I can not use the buttons to arm/disarm the system. No matter what button I press, my base station just says, "Alarm off". I'm guessing it's an app issue and not a phone issue since I tested on 3 devices. Kind of aggravating a key feature of this system doesn't function properly.

Captain

 • 

4.6K Messages

1年前

@ waters.webdesign suggest you call support to troubleshoot. App is working fine on my Pixel 4a.
I was told it was a device issue. The chance of that being the case for three separate devices is extremely unlikely.

Community Admin

 • 

469 Messages

1年前

Hi @waters.webdesign,

Have you tried arming your system through your account on SimpliSafe.com instead of through the SimpliSafe app? If you experience the same issues through SimpliSafe.com then it is most likely an issue with the Base Station. I seem to recall this being an issue a year or two ago that was later resolved with a firmware update. Check on your Keypad to see if there is a ‚öô Gear icon on the left side of the screen regarding a firmware update. Also, if you haven't already, try resetting your Base Station using these steps:

  1. Remove the power adapter.
  2. Using a Phillips-head screwdriver, remove the screw holding the battery cover in place, and then remove the battery cover.
  3. Remove one of the batteries from the Base Station--this ensures there is no power going to the Base Station, which is important--and wait for about 10-15 seconds.
  4. Reinsert the battery.
  5. Close the battery compartment and use the screwdriver to reseal it.
  6. Plug the power adapter into your Base Station

SimpliSafe Social Team
SimpliSafe Home Security