B

Sun, May 31, 2020 5:35 PM

Simplisafe with Arris DG3450A -- WiFi Password Incorrect

Has anyone else experienced the inability to connect to WiFi with an Arris modem/router?

I can setup the same SSID/Password on my phone hotspot and the base unit can connect to it without issue.
But trying to connect to my Arris router, the same one where I have 22 other devices connected without issue, I continue to receive incorrect password.

I know the password and SSID are correct.

I am not using any special characters and using the minimum character lengths.

Calling SS support, no real troubleshooting or diagnostics, just that they are sending me another base unit.

I am not confident another base unit will correct the issue.

I also used my phone hotspot to get my base unit up to date.

I'm thinking I'm going to have to return this $500 system for lack of wifi support.

4 Messages

Il y a 1 a

Hi Johnny
My keypad says Version 1.6.2. But I checked for updates and it said I was up-to-date, so how can I get Firmware 2.1?
John

4 Messages

Il y a 1 a

I just received a new keypad to see if that worked, but it doesn't. The version on it is 1.4.20. Why can't the latest firmware be put on replacement bases and keypads?

Community Admin

 • 

3.1K Messages

Il y a 1 a

Hi jfoprea,

You mentioned that you had previously connected your system to your friend's home WiFi? The Base Station can only update via WiFi, so that's an important piece.

Another quirk of the system prior to Firmware 2.1, is that using the "Check for Updates" feature only checks if an updated was ready for your Base Station; it doesn't request one. So your system might not have been connected for long enough for our server to allow the update.

Is it possible for you to have your system connected to WiFi at the same time as being on the phone with our Support team? Our Agents can force-send the update to your system so you can initiate the download from your end.

- Johnny M.
SimpliSafe Home Security

4 Messages

Il y a 1 a

Johnny
Thanks, that worked and I can connect to my wifi. Let me just suggest that, with known issues and fixes like this, Simplisafe actually email users to inform them. It shouldn't be necessary to do a Google search to find the appropriate forum help topic. At the very least Simplisafe tech should inform customer reps. Put this in the suggestion box. Thanks again.
John