K

Tue, Nov 17, 2020 7:12 PM

Unable to connect to dispatch center since end of October 2020

Has anyone else been unable to get their Original SimpliSafe system to connect to dispatch center? Especially curious if others who live in North Carolina have had this issue.

Community Admin

 • 

469 Messages

Il y a 2 y

Hi @kefine,

It looks as though you have already gotten in touch with our Support Team but just to make sure, we'll make sure to have someone reach out to you shortly to confirm.

SimpliSafe Social Team
SimpliSafe Home Security

2 Messages

Yes I have spoken with your support team on six different occasions since this became a problem. Still trying to get it resolved. I was curious if other users in my area are experiencing this issue-especially if this is a cell tower issue.

Captain

 • 

4.7K Messages

Il y a 2 y

@ kefine I am in the greater Chicagoland area and no connectivity issues. I have SS3 and an newly replaced comm board with a 4G Verizon SIM.  One question: has anyone at SS talked to you about upgrading your comm board yet? The 2G comm board in the base is being phased out and may have already been shut down in your area.

Advocate

 • 

2.8K Messages

Il y a 2 y

Honestly, I think SS should start sending notices every day regarding the modules, to those they know need them updated - people shouldn't have to ask, that's SS' job, notify your users! (if that's indeed the issue).

1 Message

Il y a 1 a

I'm having the same issue with the original Simplisafe System, i.e. it cannot connect to the dispatch center.  This is a very recent problem.  I was able to speak to customer support after being on hold for about an hour.  They did send a replacement base station but that too has the issue, so I'm sitting on hold once again.  Very frustrating problem, as is the lack of timely customer support.
I'm having the same issue - started this month.  I'm North of Boston.

Community Admin

 • 

2.9K Messages

Il y a 1 a

@jtk1967,

It sounds like since we've already replaced your Base Station, it should already be updated to the latest cell module, including 4G connectivity. Yours might be more of a cell coverage situation. Do you know if you have good coverage for Verizon in that area? Something might have changed recently in their network.

I do see on your account that you were able to get hold of our Support team yesterday. But if you still need help, we can get you in touch with one of our specialists.

- Johnny M.
SimpliSafe Home Security

23 Messages

Il y a 1 a

@timothy.maclean Suggest you call Simplisafe at 800-548-9508 (8:00am~Midnight, ET) to talk to one of their representatives.

2 Messages

Il y a 1 a

Yes,it has been happening 90% of the time over the last few months. We have an original system and am guessing it could be a firmware issue. We sent an e-mail today to support ( can't wait an hour + on the phone), no answer yet.