P

Wed, Aug 5, 2020 11:49 PM

Unable to get firmware updates

Hi. So I'm a bit stumped on this. My base station and keypad had not had a firmware update for I think over 1 year. I can't remember the base station firmware version, but it was maybe 1.3, and I can't remember if it ever actually got an update.

I called simplisafe multiple times and they pushed the most recent firmware (1.6) multiple times but it never worked. Then they sent me at least 3 new base stations and those also would not receive updates. At one point they sent me a new base station and keypad, but that didn't help either.

I turned my router firewall completely off for at least 24 hours during one of these attempts and that didn't help. Even with the firewall on, I have no problem accessing my system from outside the home's wifi. And the simplisafe customer service representative was able to go in from her computer and arm/disarm my system, so it did not seem that my firewall was blocking outside access to the base station. All my other gadgets on my wifi receive firmware updates without issue when the router's firewall is on.

One would expect that with the number of base stations I've been sent there's something about my ISP (comcast) or firewall that is interfering with the update process, but I'm not sure how this could be at this point.

I even tried using my cell phone as a hotspot and tethering the base station to the cell phone but this didn't work either.

Current base station firmware is 1.4.62 (the version this base station shipped with.)

Does anyone have any ideas? This is a SS3 system.

Thanks in advance!
No Responses!