justinform's profile

Sun, Jan 9, 2022 9:51 PM

3 months and 100s of dollars for...?

So, we've had the system for three months and I am not being hyperbolic when I say this service has been the most disappointing and frustrating experience I've ever had with a service or any other smart home tech I've bought and installed. 

After initial setup, the keypad stopped responding at the end of the first week and kept saying it was out of range. I'd power cycle it and have to setup all the sensors in the house, just to have it work for a day or less. I cannot say just how many times I had to set up all the sensors again, but it was quite a few. After a call to customer service, and power cycling both the keypad and base station, they opted to replace the keypad. 

That seemed to work for a little over a month. Then we went on a road trip just before the holidays and armed the system when we left. The first night out I got a notice that the system had armed itself (weird) and when I went to check the app, it said it couldnt connect to the system. I tried for the several days we were away but to no avail. When we finally got home, it was clear the system had turned off and was not connected. There was no beep when we entered and the keypad would not connect at first. 

After another power cycle, the system wanted me to activate all my entries again. I really did not want to do this dance all over, so I called and we went through the same process again with customer service (power cycling both, etc) and they said the base station was faulty this time and would send a new one. 

The new station arrived, but I put off setting it up until today because I didn't really feel like struggling and activating all the sensors again. Alas, when I tried to switch to the new base station via the app, the process crashed and the app told me to call sutomer service. I did. 

During the first call I power cyccled the base station at the agent's behest. I did and she said it appeared to be connected and asked if I needed anything else. Confused, but optimisitic, I said okay and tried the app setup. I got the same error and crash again. 

So I called, again, and again I had to power cycle both the keypad and the new base station (unscrewing the screw, taking batteries out of both and putting them back in, every single time). No good. The agent then had me do it again but put me on hold for a full 2-3 minutes while we waited for a better result. 🤦‍♂️ 

Still no good. The keypad can't find the base station. So I'm getting a new keypad. 

At this point I have to wonder if two base stations and three keypads can't get me going, what level of peace of mind should I really expect from this system? That's what this is for, right? To protect our families and our homes and hopefully get some piece of mind, right? The only time I've ever needed this thing was a failure. The impression that I now have is that the primary devices are so faulty they just keep shipping out new ones. 

I really just want to return the entire thing— no, I want to dump the entire system into a flaming 55 gallon drum with a bushel of sage and a King James Bible so I can hopefully prevent the ghosts of this horrible service from ever haunting another house in the future. 

Yet here I am writing this and waiting, knowing I'm going to try this third keypad because I've already sunk so much time into this process that I'm hoping for something before I lose my mind. And while I may be damned to the hell of repeating the setup process from now into enternity, like some modern Sisyphus, rest assured that any ears capable of hearing my warnings of woe shall savor my song of staying away from SimpliSafe from now until the end of time. 

40 Messages

Il y a 7 m

I concur. I’ve had this system about a year now and cannot count the number of times I’ve armed in home mode in the evening and when I wake up to disarm its either already off somehow, or the keypad reboots. Not to mention the cameras picking up motion as cars/people are leaving the property.  Will not recommend to anyone   

Community Admin

 • 

2.9K Messages

Il y a 7 m

Hi Justin,

 

So sorry about this not-so-great experience!

 

That first issue you mentioned, with the Keypad saying it was out of range, and then having to re-add your sensors to the system. That shouldn't be happening at all. After a reboot, the Base Station should still have all of the sensors in its memory. So yes, the correct move should have been to replace your Base Station - replacing the Keypad wouldn't do anything.

 

When the new Base Station is sent, it should have been pre-programmed with all of that our server has from your previous Base Station. So the only thing you should have needed to do was update your online account with the new Base Station's serial number.

 

I'm going to have a Specialist reach out. There's obviously something out of the ordinary going on with your system or account, and we need to get to the bottom of it.

2 Messages

@davey_d​ I received a new base station on 12/24. When I replaced it via the app, I followed these directions: 

https://support.simplisafe.com/hc/en-us/articles/360057205732-How-do-I-transfer-service-to-a-new-Base-Station-

The process failed at step 6, after entering the serial. I tried several times. 

When I called, the first rep said it looked great on their end, and to try again, and ended the call. 

When I called again, a different rep went through that super lengthy process of power cycling the keypad and base station twice with me, and it still didn't work. That was Sunday 1/9. They said they would overnight a new keypad. 

Well, I just got the notification that the keypad shipped last night, 1/13. 

11 Messages

Il y a 7 m

We have had so many issues with our new SimpliSafe system. I have been on hold with them over 155 minutes in one week.  SimpliSafe is SimpliJunk.

23 Messages

Il y a 7 m

Also crap that SimpliSafe has to suck money out of you just to have your device work with Amazon

Every other smart device works with Alexa with JUST the initial purchase of the device...NOT requiring a subscription

Despicable policy & how they treat their customers

I spent $500 on SimpliSafe devices...but I guess that's not good enough for them... Bloodsucking policy !!! 

5 Messages

Il y a 5 m

Have you moved your tower closer to your router. That solved the problems I was having.