T

Sun, Feb 14, 2021 2:44 PM

Activation Code on Brand new Base Unit was station by existing customer

I recently purchased a brand NEW SimpliSafe system for my my new home. I set up all of the components correctly as suggested by the instructions. However, when I attempted to activate my base station, I kept receiving an error message saying that this base station was already activated. Which immediately made me think that maybe someone had hacked my system or maybe SimpliSafe sent me a refurbished unit? After speaking to customer service, I was informed that someone had mistakenly activated the serial number from my unit, which for a security company seems incredibly concerning and flawed that this was not noticed when the other customer activated the wrong device...?


I'm not sure if anyone else has experienced this issue? I really don't believe that SimpliSafe can be a safe option if anyone can simply enter your serial number into the activation portal and have access to your system before you even open the box.

Captain

 • 

4.7K Messages

Il y a 2 y

@trentwash10 Customer of almost 9 years, satisfied and yes, would buy again, as would the 24+ other friends, family, neighbors and coworkers would.  Yes, SS has its faults, gaps etc and they screwed up and should be held accountable. That said, if you will sleep better, get a new base and move on. Or, return it and get a full refund within 60 days.

Advocate

 • 

2.2K Messages

Il y a 2 y

What makes you think that this mistake would give anyone access to your system?  The things which allow access are your email address which they would not have, your PIN, which you set, and your safe word, which you set.