E

Tue, Aug 18, 2020 2:47 AM

Base station will not connect

I've had so many issues with SimpliSafe. The system is not even working right now (having issues connecting the base station and has been down for hours today so far)I just got a replacement keypad because the first one stopped working after the first week I installed this. I've been paying the monthly $25 JUST so I am able to turn the alarm on and off from the app on my phone. I still don't have my doorbell properly functioning. I had to also get a replacement camera sent. This whole system has been a nightmare and I do not recommend it.

This post refers to multiple issues that require in-depth troubleshooting. If you are experiencing similar concerns, please give us a call at 800-548-9508. Our Support team would be happy to take care of you.

Advocate

 • 

2.8K Messages

Il y a 2 y

If you have SS3:

Make sure your system is connecting to your router's 2.4ghz band and NOT 5ghz.

When connecting to wifi, try using numbers, and no special characters.

Try rebooting the base station:
Unplug adapter from base station
Unscrew the screw where the adapter was connected
Locate battery compartment, take out one battery
Wait a moment, reinsert battery, cover, screw, connect adapter
(you should hear the base station announce "welcome to simplisafe" and/or announcing it's in test mode)
You can test a sensor or two, or exit test mode via the keypad exit button.
Now try arming your system.  The base should announce the system is armed. You can then disarm the system.
If this works, you should be good to go.

If that doesn't work, call SS and ask if your base station needs a new SIM, and if it does, ask them to expedite it to you, and ask them to make sure it's activated!

Otherwise, you'll have to call them for assistance in getting your system connected.

As for the video doorbell and cameras, they've been having issues with them, and claim they are working on it.  If you feel you're not setting them up correctly, call for assistance, they can walk you through the steps.

3 Messages

Il y a 2 y

You HAVE to call and hope they actually answer the phone to get the secret to re setting. In this day and age you should be able to just do things online, but not with this company. It wouldn't be so bad if they actually answered the phone, and did what they said they would do so you don't have to call back again and again.

2 Messages

Il y a 2 y

Cant get my base station set up either. If this is such an unusal problem , why can there be a dedicated team to fix this?
I'm really disappointed.

2 Messages

Il y a 2 y

I am just done
& even though it says on the website that :

Need help? We are here for you!
800‚Äë297‚Äë1605
Support Hours:
7 Days A Week, 8:00am - Midnight, Eastern Time

For the second straight night, They are closed and no body to answer the call & are referring me to website

Captain

 • 

4.7K Messages

@barsea99  You are correct but on the Help center page it says they are closed New Years Day, and closed at 8pm eastern last night, new years eve. Don't get me wrong, SS communication is often lacking and that is the case here.

They are a good company, I suggest you give them another shot. Support will be back open on regular schedule tomorrow. Next day they are closed is Memorial Day.

3 Messages

Il y a 2 y

posted in wrong place