A

Fri, Jul 23, 2021 1:25 PM

Customer Service

I've been trying for 2 days to get ahold of customer support with absolutely nothing. I've called 4 times with my hold times being over an hour and I've sent 3 emails trying to contact them and nothing. Has anyone had any luck getting ahold of them? I'm even typing this as I wait on hold.

Advocate

 • 

108 Messages

Il y a 1 a

Unfortunately this issue with getting through to customer service seems to be happening to many people right now.  However, if you describe your problem here there are several others that might be able to help.  There's also a SimpliSafe employee that usually posts in the forums that could help.  If nothing else, it might help pass the time while you're on hold.
Also, we've been pushing SS to do something about the customer service call wait times.

1 Message

Il y a 1 a

Where is customer service?  No one is picking up the phone and we need help.  Our six month old base station is no longer accepting new settings.   Last successful update was 19 days ago.  We have not changed anything on the system. If no support then this is not a security system.  We pay for monitoring but have no way to verify that is even happening.   What gives??

Community Admin

 • 

2.9K Messages

Il y a 1 a

So sorry about the wait, ashleynmorgan and reneekreed.

Our Support team is continuing to work through extremely high call volumes, and Support leadership is doing everything they can to get it under control. We appreciate your patience, and if you stay on the line, our Support team will take care of you as soon as possible.

In the meantime, yes, if you let us know a bit more about your issue here, we should be able to offer some advice on how to get it resolved as well.

reneekreed, it does sound like there might be connectivity issues with your Base Station. Is it still linked to your home's WiFi? It might help to try the Base Station reset, with instructions you can find here. That will reboot your system and force it to look for fresh connections.

- Johnny M.
SimpliSafe Home Security

1 Message

Il y a 1 a

Initially the system was great, but 6-7 months out sensors aren't working properly, the base station had to be replaced.  Called for help because the new one came and looked like it had been run over by a truck.  Never was able to get through to customer service.  I was sent one return label for one item, but the second one came through blank.  I finally got my system up and running myself without their help.  I am definitely not happy with situation.  When I've called in the past I've had very mixed results when I've acutally be able to get through.  One representative had no clue what the problem was, so her solution was to hang up.Had to call back several times.... When I finally did get through I did  finally
get someone who seemed to understand the problem and could solve it. Try cloning him....he was great!