edwoodliff's profile

Tue, Jun 7, 2022 4:21 PM

Module Upgrade to 4G and APP issues

I have been a customer for 6 1/2 years.  Throughout the first 6 years and much more recently, my system was very finicky about picking up the Verizon cell signal.  Sometimes it would, other times it wouldn't.  The help desk kept saying move base station location, reset it, etc. (something one has to do if in the home...what if I am away on vacation, hello?) without really any good solution.  I just figured I was on a fringe area of receiving a Verizon signal and that is the way it was.

Enter 2022.  After calling in January to the help desk to find out why I could talk to my system with my cell phone app but yet the system could not link up with Verizon half the time.  The technician said "I notice you have not upgraded your module.  I will send you a new one (4G) for you to install and we can help if needed".  NOTE:  I did not know I needed a new module!!  Upon replacing the module in January and since that time, I have had NO "no link to dispatch" messages and no signal problems.  Hooray!  If I had only known this before I could have eliminated all the stress I endured when I was away from home. 

 SimpliSafe...WHY DID YOU NOT INFORM ME EARLIER DURING THE MANY TIMES I HAD CALLED IN WITH PROBLEMS.  YOU ARE LUCKY I AM STILL A CUSTOMER.  

Community Admin

 • 

2.9K Messages

Il y a 2 m

Hello @edwoodliff ,

I'm very sorry to hear about what you've been through. We definitely have been more aggressive with updating all customers to 4G starting this year.

But replacement cell modules have always been an option when troubleshooting connectivity issues for your Base Station. Of course, we do always want to go through the proper troubleshooting steps, to eliminate environmental issues.

But I'm really glad to hear that the upgrade to 4G did the trick, your system is now working properly. Hopefully you won't have any further trouble from here on out.