funkiewagnalls's profile

Mon, Dec 14, 2020 8:50 PM

Release 2074.50.0 bricked the app on my iPhone 11 - "No Connection - Were currently experiencing server issues".

The latest release is broken. Will not start at all on my phone. Others reporting the same issue.

Community Admin

 • 

469 Messages

2年前

Hi @FunkieWagnalls,

We're sorry that you're having issues with the latest update to the SimpliSafe app. We're aware of that bug and expect to have an update to address that issue soon. In the meantime, a workaround that has worked for some of our users is to force-close the app through the app switcher and then re-open it.

SimpliSafe Social Team
SimpliSafe Home Security

1 Message

@FunkieWagnalls, I've been having the same problem for a couple of days now. I just talked to SimpliSafe tech support. They said there is no expected fix date and I should call back middle of next week for an update. That's ridiculous.
@SimpliSafe, This is my home security. How can you expect us to find a week of your servers being down as acceptable?

4 Messages

2年前

I was experiencing the No Connection bug on version 2074.50.0.  It seemed to happen if the App was running, phone went to sleep, and upon awakening the App error occurred.  Had to close App and restart it.  Today, I got the updated 2074.51.1.  Will see if it behaves tonight & tomorrow.  Thank you to SimpliSafe Support for releasing the update.

4 Messages

Three days later and the iOS App update to 2074.51.1 remains stable and all functionality is operating properly. Thanks SS Support.